If you are getting an error in the installation process similar to this one:

  ICU version Failed Internationalization support ICU 49.0 or higher is required when you want to use,ICU Data version Failed Internationalization support ICU Data 49.1 or higher is required when you want to use … 

 

We always advise you to contact your hosting and upgrade ICU version to the one required by Yii2 framework, but From previous experiences, version 4.2.1 is also OK with EasyAds features.

 

So if you have that version and you want to proceed with the installation, Please edit this file web/engine/data/requirements.php and make the ICU :

'mandatory' => false,